"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Aktuelle Sicherheitslücken

Hansmaulwurf 20.04.2014 - 11:17 53092 157
Posts

Hansmaulwurf

u wot m8?
Avatar
Registered: Apr 2005
Location: Wien
Posts: 5307
lol


edit:
Sorry, Thread übersehen:
https://www.overclockers.at/laptops...993#post3818993
Bearbeitet von Hansmaulwurf am 11.05.2017, 12:59

GrandAdmiralThrawn

XP Nazi
Avatar
Registered: Aug 2000
Location: BRUCK!
Posts: 3246
Grade ein Elitebook bei uns geprüft, aber is wohl noch der alte Treiber drauf. Die Datei existiert, ist (und bleibt) aber leer. Mein Elite X2 bekomme ich wohl morgen zurück (war bei atFolix, zur Bestückung mit einer Mattierfolie). Bei dem Trumm hab ich auch noch Win10 drauf, und ganz sicher Mal den Audiotreiber aktualisiert! Bin gespannt, wie das File auf der Maschine ausschaut.

Edit: Ah, is eh auch verwundbar, wenn das File leer is. Nur ein älterer Treiber, der statt dessen in die Debug API logged...
Bearbeitet von GrandAdmiralThrawn am 11.05.2017, 13:25

wergor

fantasiebefreit
Avatar
Registered: Jul 2005
Location: graz
Posts: 2985
patch verfügbar.

Lord Wyrm

wastelandwarrior
Avatar
Registered: Jan 2005
Location: Amstetten
Posts: 1156
Kategorie Designfehler.

semteX

salty as fck
Avatar
Registered: Oct 2002
Location: lnz
Posts: 12991
fuck, auf die diee da ein OSD keyboard drüber zu legn musst mal kommen... aber ja, what could possibly go wrong

Hansmaulwurf

u wot m8?
Avatar
Registered: Apr 2005
Location: Wien
Posts: 5307

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: sbg
Posts: 24478
Bei mir funktioniert es nicht. Zumindest nicht beim Unlocken der Settings.

Es ist scheinbar eine ganz spezielle Konstellation, die den Fehler hervorruft.

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 14739
so speziell sollte sie nicht sein laut unseren tests.
unlock der settings war bei hochgezogenen systemen als auch neu aufgesetzten möglich. ab und zu hab ich 2-3 mal drücken müssen.
lücke ist schon ein grober fehler und hätte auffallen können. jetzt stellt sich nur noch die frage wie schnell es gefixt wird.

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: sbg
Posts: 24478
Jetzt hab ichs auch geschafft. :eek:

Vorher ging es mit zahlreichen Versuchen nicht. Es wurde auch der Login-Name immer wieder auf meinen User umgestellt. Jetzt wo es funktioniert hat, blieb der "root"-User im Anmeldedialog stehen und danach funktioniert es auch.

Wow, dazu würde ich gerne den Code sehen ...

Code: C
if (secondlogin && strcmp(username,"root") == 0)
    loggedin = true;

:confused:

Dreamforcer

New world Order
Avatar
Registered: Nov 2002
Location: Tirol
Posts: 7427
intressant wärs was passiert wenn das volumen mit filefault zu is, obs dann auch auftritt

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 14739
Zitat aus einem Post von mat
Jetzt hab ichs auch geschafft. :eek:

Vorher ging es mit zahlreichen Versuchen nicht. Es wurde auch der Login-Name immer wieder auf meinen User umgestellt. Jetzt wo es funktioniert hat, blieb der "root"-User im Anmeldedialog stehen und danach funktioniert es auch.

Wow, dazu würde ich gerne den Code sehen ...

Code: C
if (secondlogin && strcmp(username,"root") == 0)
    loggedin = true;

:confused:

ich würd mal auf einen config fehler tippen als auf code-fehler. irgendein flag nicht gesetzt oder übersehen.

Zitat aus einem Post von Dreamforcer
intressant wärs was passiert wenn das volumen mit filefault zu is, obs dann auch auftritt


ja tritt auch auf. das ist das eigentlich schlimme und IMHO mehr ein tatsächliches risiko.

normal kannst ja - wenn file vault nicht aktiv - das passwort extrem easy zurücksetzen. klar, man verliert dabei den großteil der keychain, aber ohne lücke/bruteforce kommst an die idr halt nicht ran.
passwort zurücksetzen im terminal geht aber bei verschlüsselter disk meiner erfahrung nach nicht. die disk bzw. gewisser speicher ist jedoch nicht ganz verschlüsselt, es gibt pre-boot bereiche, die logischerweise gelesen werden können.
Bearbeitet von Smut am 29.11.2017, 10:35

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: sbg
Posts: 24478
Nur um das auch hier festzuhalten: Es muss ein Passwort für den root-User erstellt werden.

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 14739
hm.
also der root benutzer kann deaktiviert sein und es funktioniert.
passwort muss man keines setzen, oder meinst du man muss ein passwort setzen um dann weitere aktionen zu treffen?

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: sbg
Posts: 24478
Bei mir muss ich dann das neue root-Passwort eingeben. Default ist scheinbar keines.

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 14739
Immerhin. Schnelles Update.
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz