"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Magenta/UPC: Ipv6 Setup mit OpenWRT

Smut 10.08.2019 - 13:55 4981 6
Posts

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
ich komme aktuell mit folgendem vorhaben nicht weiter - es ist mir aber noch nicht ganz klar woher das problem kommt.


ziel:
Magenta (UPC) ipv6 und ipv4 internet mit eigenem OpenWRT Router dazwischen.

setup:
internet => upc connect box => open-wrt router (wan-port) => div. clients am LAN-port

problem:
connect box modem mode: IPV6 Only Funktioniert im modem-mode. jedoch funktioniert kein ipv4 via ds-lite
connect box im router mode: ipv4 funktioniert via ds-lite, ipv6 funktioniert nur am open-wrt router jedoch nicht auf clients, da sie keine v6 adresse bekommen.

vermutung:
router bekommt am WAN-port eine /128 IP sowie einen /64 prefix.
jedoch bekommt das LAN interface diesen prefix nicht weitergereicht (sollte es für DHCP-verteilung als auch RA bekommen)
im modem-mode erhält der router ein /57 prefix und das lan interface einen /64 zur weiteren verteilung an die clients.


Details:
UPC-Connect box (Arris Modem mit docsys3.1)
OpenWrt 18.06.2 19.07.5

/etc/config/network
Code:
config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.11.1'
	option netmask '255.255.255.0'
	option gateway '192.168.11.1'
	option dns '192.168.11.1'
	option ip6assign '64'
	option ifname 'eth0.1'

config interface 'wan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	option ipaddr '192.168.0.22'
	option ifname 'eth1.2'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

Connect-Box Konfiguration:
click to enlarge

OpenWrt Konfiguration:
1. screen: modem mode -> router erhält /57 und auch die weitere verteilung von ipv6 im netzwerk funktioniert
click to enlarge
2. screen: router mode -> router erhält ein /64, weitere verteilung von ipv6 im netzwerk funktioniert nicht.
click to enlarge



zusammenfassung:
imho liegt das problem daran, dass ich im "router-mode" direkt am WAN interface das /64 zugewiesen bekomme ohne prefix delegation und dann kein platz mehr für ein kleineres netz am lan-interface ist.
alternativ kann man das ganze vielleicht im modem mode lösen - nur bekomme ich DS nicht zu laufen. lt. upc hotline, geht das auch nicht (darauf verlasse ich mich aber mal nicht).


tia jedenfalls für input - wer hätte gedacht, dass das so kompliziet sein kann?
Bearbeitet von Smut am 23.01.2021, 11:51

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
niemand hier, der ein ähnliches setup fährt mit magenta und ipv6? kaum vorzustellen :)

mr.nice.

endlich fertig
Avatar
Registered: Jun 2004
Location: Wien
Posts: 6202
Du könntest doch das Modem im Router Modus betreiben und die internen DHCP-Dienste am Open-WRT laufen lassen.

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
das setup hab ich aktuell sogar hinbekommen - ich weiß aber noch nicht ob zufall oder stabil. sobald ich es durchschaut habe, werde ich es erklären.

die oben gefragte variante hab ich übrigens kurzzeitig sogar zum laufen gebracht im "modem-mode" allerdings hatte ich mit DS-lite (v4 in v6 getunnelt), heiße 5mbit während ipv6 native die gewohnten 930mbit liefert.

seit heute bin ich im "router-mode" mit passthrough DHCP und RA-server am openwrt. das könnte die lösung sein. ganz sattelfest bin ich mit der materie aber noch immer nicht :(

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
Thread ist schon ein paar Tage alt :)

Mittlerweile verwende ich die neueste openWRT 19 version aber bekomme es noch immer nicht hin.
Hat jemand von euch das sauber hinbekommen?

Tia

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
gut. mittlerweile hat magenta wieder ein update des modems nachgeschoben. seither klappt nicht mal noch die /64 prefix delegation mit openWRT. falls jemand tipps für eine funktionierende config mit magenta + ipv6 + openwrt hat - danke

Smut

takeover & ether
Avatar
Registered: Feb 2003
Location: VIE
Posts: 16533
ich wäre das thema noch mal auf.
seit einem update vor ca. einem jahr reißt mir IPV6 nach ca. 2-3 tagen jeweils ab. ist nicht ganz genau sondern immer schwankend also kein timer der abläuft.
konkret verlieren alle adapter die ipv6 adresse. den grund dafür hab ich noch nicht rausgefunden.

meine config ist jedenfalls wie folgt:

Code:
config interface 'wan'                    
        option device 'wan'               
        option proto 'static'             
        option ipaddr '192.168.0.33'      
        option netmask '255.255.255.0'    
        option gateway '192.168.0.1'      
                                          
config interface 'wan6'                   
        option device 'wan'               
        option peerdns '0'                
        option proto 'dhcpv6'             
        list dns 'fd5f:2c3a:6c67::300'    
        option reqaddress 'try'           
        option reqprefix '64'             
        option ip6assign '64'             
                              




click to enlarge


magenta modem/ connect box version: AR01.04.055.05.01_022422_7245.SIP.10.MG.X1
openwrt version: OpenWrt 22.03.2 r19803-9a599fee93



tipps wären nice. ev gibt es ja irgendein setting in openwrt mit dem ich das blöde verhalten des modems ausgleichen kann.
hab einen gigabit anschluss und dazu ein aktiv gekühlte modem von magenta. ich denke wechsel auf ein neues modem ist nur ein rückschritt momentan.
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz