"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

QNAP 5Gbe USB-Adapter

Joe_the_tulip 11.04.2021 - 13:15 568 8
Posts

Joe_the_tulip

Editor
banned by FireGuy
Avatar
Registered: Mar 2003
Location: Wien
Posts: 15870
Zum Herumspielen hab ich mir zwei QNA-UC5G1T gegönnt. Davon hängt einer am Synology NAS (Anleitung und einer am PC via USB3.

Hardware:
NAS: DS920+
PCs: HP Elitebook 840 G5 (PC1), Dell XPS13 2017 (PC2); beide mit >500MB/s SSDs bestückt.
Router: Qnap Qhora 301W
Kabel: Cat 6a aufwärts.
TB3-Dock: im Dell U3818 integriert

Installation:
Schnell und problemlos. Der Adapter hat die eigenen Treiber gleich mit und Windows macht keine Mätzchen. Auch am NAS recht easy. Im Betrieb wird er selbst ohne Last mit 1Gbe warm.

Ergebnisse:
Getestet wurde in folgenden Varianten (Dabei jeweils DL und ein UL von einer HDD (Seagate 10TB Ironwolf im RAID1) und SSD (Ironwolf NAS SSD)) mit einem oder mehreren ca 3GB großen MKVs via Windows-Dateitransfer:

PC1 mit NAS via Router:
PC1=>SSD 225
PC1<=SSD 180-190
PC1=>HDD 220
PC1<=HDD 150

PC1 direkt mit dem NAS:
PC1=>SSD 230
PC1<=SSD 160
PC1=>HDD 180
PC1<=HDD 145


PC1 mit PC2 via Router:
PC1=>PC2 280
PC1<=PC2 250


PC2 mit NAS via Router:
PC2=>SSD 290
PC2<=SSD 260
PC2=>HDD 200
PC2<=HDD 210-220

Probleme:
1)Offenbar ist mein TB3-Dock Kacke. Dort angesteckt schaltet er nie auf 5Gbe. Sonst nimmt er nur den 1Gbe-Modus. Transferrate - egal in welcher Kombi - ist nur 40-60 Mb/s. Up + Down

2)Offenbar hat PC1 irgendein Problem beim Schreiben.

3)Das NAS vergisst den Adapter nach Reboots und Updates => man muss im DSM das Paket stoppen und aktivieren. Sprich man muss eigentlich immer zumindest ein zweites LAN-Kabel angesteckt haben um notfalls auf das NAS zu kommen.

4)Das NAS transferiert nur dann via USB-Adapter, wenn die anderen Ports keine Verbindung haben - völlig egal was ich eingestellt habe.


Rückschluss und Ausblick:
1. 5GBe schaut anders aus - eigentlich erreiche ich nur 2,5GBe.
2. PC1 hat irgendein Problem mit dem Schreiben
3. Offenbar kann ich es mir aufpinseln diesen (jeden?) LAN-Adapter am Monitor anzustecken. Muss ich wohl doch den kommenden neuen Laptop (ASUS ROG Flow X13) jedes Mal mit zwei Kabel anstecken.

4. Ich mache nochmal Benchmarks, wenn der neue Laptop da ist.

ZARO

Here to stay
Avatar
Registered: May 2002
Location: Wien 22
Posts: 711
Habe genau den selben USB Adapter am Client hängen.
Hängt direkt an einem USB 3.2 Gen 2 Port, 5Gbit Sync.
Kabel zum 10Gbe Switch, 25m CAT5e Kabel, 10GBe Switch, 10Gbit DAC Kabel zum Ubuntzu Server.

Schaft ca 420 Mbyte/s beim SMB kopieren in einem Stream sowohl up als auch down.


Je nach dem wie du TB3 Dock benutzst, werden die vorhandene Signalleitungen aufgeteilt, eventuell hast du dann zu wenige Leitungen für USB, oder nur langsamere USB Version benutzt wird.

Joe_the_tulip

Editor
banned by FireGuy
Avatar
Registered: Mar 2003
Location: Wien
Posts: 15870
Zitat aus einem Post von ZARO
Habe genau den selben USB Adapter am Client hängen.
Hängt direkt an einem USB 3.2 Gen 2 Port, 5Gbit Sync.
Kabel zum 10Gbe Switch, 25m CAT5e Kabel, 10GBe Switch, 10Gbit DAC Kabel zum Ubuntzu Server.

Schaft ca 420 Mbyte/s beim SMB kopieren in einem Stream sowohl up als auch down.


Je nach dem wie du TB3 Dock benutzst, werden die vorhandene Signalleitungen aufgeteilt, eventuell hast du dann zu wenige Leitungen für USB, oder nur langsamere USB Version benutzt wird.

So ca 400Mb/s hätte ich mir auch erwartet. 5gbe sollte ja 550Mb/s schaffen. Ist die Frage ob sich die Verluste quasi addieren - sprich von 550 auf 420 mit einem Adapter und von 420 auf 290 mit dem zweiten.

TOM

Legend
Oldschool OC.at'ler
Avatar
Registered: Nov 2000
Location: Vienna
Posts: 6746
Hier ein bisschen anderer Input bzgl. MultiGig USB-Adapter:

https://www.youtube.com/watch?v=uqYdWnmt-Kk
https://www.youtube.com/watch?v=wGRjZDnWUb8

... ist halt nicht ganz das wahre

Gscheite/leistbare 5GbE PCIe Karten wären nice, ohne irrsinnigen Stromverbrauch/Hitzeentwicklung... bisher leider nichts gesehen in die Richtung (10GBe scheinen im Homeuser Bereich einfach noch overkill zu sein => Strom/Hitze/Kosten/zu viele Bottlenecks)

Römi

Hausmeister
Avatar
Registered: Feb 2001
Location: Bez. Tulln
Posts: 4892
Überlege auch schon lange upzugraden, 2.5G (oder 10g)...
Ich hab einen 2.5G usb adapter bestellt auf den ich noch warte mal zum schaun ob das halbwegs funktioniert, 2.5G switches werden langsam bezahlbar.
USB ist sicher nicht erste wahl, aber zb mit mini itx oder sff pcs hat man nicht viel andere möglichkeiten.

10g/glas wär wahrscheinlich gscheiter, aber das ist mit meinem setup leider noch wenig kompatibler. 1G sollt langsam wirklich sterben (oder zumindest ersetzt werden)

Bezüglich Joes setup, glaub ich auch dass da das Problem in richtung USB oder dock liegt..

NiL_FisK|Urd

Addicted
Avatar
Registered: Dec 2017
Location: Wien
Posts: 376
Wenn man auf verschlüsselte Shares schreibt, ist man mit normalen NAS aktuell mit 2,5 GBit gut dabei - ich hab im DS1621+ eine Mellanox ConnectX3 und am Notebook über TB3 auch eine ConnectX3 und bekomme folgende Geschwindigkeiten:

(DS1621+, 32GB RAM, RAID6 mit 6x8TB WD White Label)

unverschlüsselt:
DS1621+ R (MB/s) W (MB/s) R (IOPS) W (IOPS)
SEQ1M Q8T1 1044,71 977,72 996,31 932,42
SEQ1M Q1T1 868,59 851,02 828,35 811,59
RND4K Q32T1 184,72 137,34 45096,92 33531,01
RND4K Q1T1 52,18 40,16 12739,99 9804,2

verschlüsselt
DS1621+ R (MB/s) W (MB/s) R (IOPS) W (IOPS)
SEQ1M Q8T1 1031,13 325,06 983,36 310,01
SEQ1M Q1T1 874,1 281,45 833,61 268,41
RND4K Q32T1 177,35 79,46 43298,58 19400,15
RND4K Q1T1 51,56 32,26 12586,91 7875

Unverschlüsselt hab ich je nach Dateigröße fast die 10 GBit, verschlüsselt steht ich bei ca. ~280 MBps.

Joe_the_tulip

Editor
banned by FireGuy
Avatar
Registered: Mar 2003
Location: Wien
Posts: 15870
Ich glaub ein TB3 Dock mit 10Gbe ist fast noch die günstigste Lösung.

Viper780

Er ist tot, Jim!
Avatar
Registered: Mar 2001
Location: Wien
Posts: 42726
Hast du die ConnectX3 direkt miteinander verbunden? Die Karte kann ja 40Gbit (eigentlich 52Gbit aber da muss viel zusammen passen)

NiL_FisK|Urd

Addicted
Avatar
Registered: Dec 2017
Location: Wien
Posts: 376
Von den ConnectX3 gibt es einige verschiedene Versionen, meine haben einen SFP+ und können nur 10 GBit - und der TB3-Anschluss von meinem Thinkpad ist auch nur mit 20 GBit angebunden.
Dazwischen hab ich einen QNAP QSW1200 Switch. Die ConnectX3 mit QSFP+ können 40 GBit, aber da würde ich dann auch wieder einen anderen Switch brauchen - mal abgesehen davon, dass 40 GBit bei mir kompletter overkill wären.
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz