"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

RTL8125 2,5 Gbit Connection drops

schichtleiter 23.01.2021 - 16:48 381 4
Posts

schichtleiter

Big d00d
Avatar
Registered: Sep 2006
Location: OTK4Life
Posts: 269
Hier ein Infothread für Leute, die dieselbe (crappy) 2,5Gbit Karte auf ihrem Mainboard verbaut haben:

Die Karte scheint mit aktuellen Treibern und BIOS-Versionen einen Bug zu haben, der dafür sorgt dass bei hoher UDP-Netzwerklast die Connection randomly gedroppt wird.

Mit folgenden Einstellungen scheinen zumindest während meinem aktuellen Test keine Probleme aufzutreten:

- aktuellster Treiber direkt von Realtek
- UEFI Netzwerkstack deaktiviert
- Geräte-Manager => Geräte-Eigenschaften => Energieverwaltung: [ ] Computer kann das Gerät ausschalten um Energie zu sparen
- Geräte-Manager => Erweitert => Abladung großer Übertragung V2 (2x, IPv4 und IPv6) => deaktiviert
- Geräte-Manager => Erweitert => Advanced EEE => deaktiviert
- Geräte-Manager => Erweitert => ARP-Abladen => deaktiviert
- Geräte-Manager => Erweitert => EEE Max Support Speed => 1,0 Gbit
- Geräte-Manager => Erweitert => Energy-Efficient-Ethernet => deaktiviert
- Geräte-Manager => Erweitert => Geschwindigkeit und Duplex => 1,0 Gbit
- Geräte-Manager => Erweitert => Gigabit Lite => deaktiviert
- Geräte-Manager => Erweitert => Green-Ethernet => deaktiviert
- Geräte-Manager => Erweitert => IPv4-Prüfsummenabladung => deaktiviert
- Geräte-Manager => Erweitert => Power Saving Mode => deaktiviert
- Geräte-Manager => Erweitert => TCP-Prüfsummenabladung (2x, IPv4 und IPv6) => deaktiviert
- Geräte-Manager => Erweitert => UDP-Prüfsummenabladung (2x, IPv4 und IPv6) => deaktiviert


Hoffe es hilft vielleicht jemandem, der mit diesem Chip ebenfalls random packetloss oder Verbindungsabbrüche hat.

So long,

schichtleiter
Bearbeitet von schichtleiter am 23.01.2021, 16:50

COLOSSUS

# pkill -9 .
Avatar
Registered: Dec 2000
Location: Wien || Stmk
Posts: 11004
Und damit hat man unterm Strich dann 1Gbps Bruttobandbreite am Link? Zahlt sich ja echt aus, diese NIC! :D

schichtleiter

Big d00d
Avatar
Registered: Sep 2006
Location: OTK4Life
Posts: 269
keine Ahnung ob 2,5 Gbit überhaupt gehen würde... Hab keine Hardware dafür,
vllt gehts ohne die Offloads eh mit 2,5 Gbit Einstellungen.
Aber ja, ist trash, so wie die meisten aktuellen 2,5Gbit Karten/Chips, auch die Intel Dinger haben einen Hardwarebug.

Wenn ich mal über 1 Gbit aufrüste hol ich mir sowieso gleich 10 Gbit Karten / Switch, 2,5 Gbit find ich generell entbehrlich.
Bearbeitet von schichtleiter am 23.01.2021, 20:00

ccr


Avatar
Registered: Jul 2001
Location: am Dach
Posts: 5144
Läuft bei mir an einem 2.5Gbit Switch völlig problemlos, 288MB/s sind drin.
Bearbeitet von ccr am 23.01.2021, 20:52

schichtleiter

Big d00d
Avatar
Registered: Sep 2006
Location: OTK4Life
Posts: 269
Freut mich für dich, vllt tritt der Bug ja nur im Gigabit Betrieb oder bei nicht Z570-Boards auf?

http://forum.asrock.com/forum_posts...s-reset-problem
https://forum.gigabyte.us/thread/98...adapter-problem
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz