"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Legends never die: GPUPI

mat 06.11.2014 - 01:52 401651 878 Thread rating
Posts

NeM

OC Addicted
Registered: Oct 2004
Location: Austria
Posts: 4887
Programm startet fehlerfrei, CPU wird auch korrekt erkannt beim Klick auf Calculate (Phenom II X4 945)

Im Fenster steht

"Devices found that don't support double precision:"

Danach kommt nix mehr (Radeon 5770 @ Catalyst 14.4, also ned der aktuelle 14.9). Schätze wenn man den Doppelpunkt nach dem Satz wegnimmt, funktionierts bei mir "as intended" :D

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 13860
aja die "devices found that don't support double precision:" meldung kommt bei mir auch beim start

XXL

insomnia
Avatar
Registered: Feb 2001
Location: /dev/null
Posts: 15703
irgendwie blöd das opencl immer nur den chipnamen hinschreibt bei amd:
bench_198201.png

aber da wäre wieder interessant wie die anderen tahitis hier getaktet sind :D

userohnenamen

leider kein name
Avatar
Registered: Feb 2004
Location: -
Posts: 15850
Zitat von mat
Was mir bei euren AMD-Screenshots sofort auffällt: Die Reduction-Time ist verdammt mies! :eek:
Versucht mal, ob bei "Reduction Size" 128, 256 oder 512 was bringt!

Code:
Selected device: Tahiti
OpenCL 1.2 AMD-APP (1573.4) is ready.

Compiling OpenCL kernels ... done.

Calculating 1.000.000.000nth digit of PI. 20 iterations.

Allocated device memory : 671088640 Bytes
Batch Size              : 20M
Reduction Size          : 128

 00h 00m 01.004s Batch  1 finished.
 00h 00m 09.541s Batch  2 finished.
 00h 00m 18.097s Batch  3 finished.
 00h 00m 26.628s Batch  4 finished.
 00h 00m 35.162s Batch  5 finished.
 00h 00m 43.664s Batch  6 finished.
 00h 00m 52.180s Batch  7 finished.
 00h 01m 00.691s Batch  8 finished.
 00h 01m 09.202s Batch  9 finished.
 00h 01m 17.709s Batch 10 finished.
 00h 01m 26.208s Batch 11 finished.
 00h 01m 34.748s Batch 12 finished.
 00h 01m 43.264s Batch 13 finished.
 00h 01m 51.785s Batch 14 finished.
 00h 02m 00.293s Batch 15 finished.
 00h 02m 08.793s Batch 16 finished.
 00h 02m 17.309s Batch 17 finished.
 00h 02m 25.840s Batch 18 finished.
 00h 02m 34.356s Batch 19 finished.
 00h 02m 42.879s Batch 20 finished.
 00h 02m 50.544s PI value output -> 5895585A0

 GPU time for   pi calculation: 156.747 s
 GPU time for memory reduction:  13.797 s

bei 256 und 512 freezed mir das system nach batch 2, nix geht mehr außer mousemovement :eek:, vielleicht auch mit win8.1 ein problem?

ich brauch jetzt pock i gor ned 500 ...

click to enlarge
7970 ghz edition

edit: eine ausgabe des betriebssystems wär eventuell auch ned uninteressant
Bearbeitet von userohnenamen am 06.11.2014, 20:10

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 13860
Zitat von XXL
aber da wäre wieder interessant wie die anderen tahitis hier getaktet sind :D

980Mhz core, 1300Mhz memory ...macht der memory takt bei dem benchmark soviel aus nachdem deine score doch deutlich besser ist?

e: die gpu kommt btw nur auf 56°C, und der lüfter dreht gegen ende von 20 auf 21% ...da stimmt doch was nicht :D

jetzt btw 92.24s (wieder mit 128 reduction size)
schwankt ein bissl :)
Bearbeitet von InfiX am 06.11.2014, 20:12

XXL

insomnia
Avatar
Registered: Feb 2001
Location: /dev/null
Posts: 15703
bin grad draufgekommen das sogar youtube zu ruckeln anfängt wenns mal startet :D

aber bei mir geht 20m und 64 reduction am besten, mich wundern aber die anderen ergebnisse, was für einen catalyst bzw. graka habt ihr alle?

benchx_198203.png

edit:

ich glaub es liegt eher am treiber, ich hab den letzten beta drauf, muss fast dran liegen weil meine graka ist sicher net schneller als die 7970 ghz :D
Bearbeitet von XXL am 06.11.2014, 20:12

userohnenamen

leider kein name
Avatar
Registered: Feb 2004
Location: -
Posts: 15850
also ich hab jetzt den aktuellsten nicht beta treiber
beim ersten ergebnis das sogar noch eine sekunde schneller war, wars irgendein älterer

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 13860
cat14.9 bei mir, was sind das für tahitis, die <65sek schaffen? :D
e: achja, noch was, ich kann die HD5450 nicht auswählen nur CPU sonst.

gpuz_r9_280_198204.png
Bearbeitet von InfiX am 06.11.2014, 20:21

erlgrey

formerly known as der~erl
Registered: Aug 2002
Location: Wien
Posts: 4409
irgendwas passt bei mir noch nicht so ganz.
1.0.3 und egal ob ich Hawaii oder Xeon auswähle, so oder so der Xeon berechnet.
Dafür ist der OpenCL Fehler weg. :)

Ich mach mal ein Catalyst update von 14.301.1004 auf 14.301.1006.

click to enlarge

XXL

insomnia
Avatar
Registered: Feb 2001
Location: /dev/null
Posts: 15703
das schlimme ist wenn ich die reduction raufsetze wirds noch besser

benchxx_198206.png

ist halt echt die frage, das ist eine 0815 xfx 7950 mit 3 gb ram

das einzige was an meinem setup ungewöhnlich wäre ist das die graka im 2ten pci-e slot steckt weil sonst der kühler keinen platz hat aber ehrlicherweise sollte gerade das die leistung leicht drücken :D

Garbage

Administrator
The Wizard of Owls
Avatar
Registered: Jul 2000
Location: GR.ch|TI.ch
Posts: 11279
Zitat von InfiX
cat14.9 bei mir, was sind das für tahitis, die <65sek schaffen? :D
e: achja, noch was, ich kann die HD5450 nicht auswählen nur CPU sonst.
die hd5450 kann kein dp, deswegen gehts nicht.

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 25396
Wieder eine neue Version: 1.0.5

Bei 1.0.4 habe ich gleich nach dem Hochladen einen Bug entdeckt. ;)

  • Windows XP Support (hoffentlich ... bitte testen!)
  • Neues Icon mit Turrican-Avatar im Hintergrund (Vorsicht: Der Icon-Cache kann etwas hartnäckig sein, hier ist der Fix ... oder einfach warten).
  • Bugfix: Ignorierte Devices werden nun korrekt mit Namen beim Start des Benchmarks gelistet

Download: GPUPI Beta 1.0.5 (111 KB)[/preview]

Error404

Dry aged
Avatar
Registered: Mar 2006
Location: Kimosabe
Posts: 2968
ein kleines Tool das einem sagt ob die verbaute GraKa DP kann wär sinnvoll, gibts aber nicht denke ich.

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 13860
Zitat von Garbage
die hd5450 kann kein dp, deswegen gehts nicht.

dann is klar, aber die R9 280 sollt eigentlich trotzdem mindestens so schnell wie eine HD7950 sein, also irgendwas stimmt da noch ned ganz :D

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 25396
Zitat von der~erl
irgendwas passt bei mir noch nicht so ganz.
1.0.3 und egal ob ich Hawaii oder Xeon auswähle, so oder so der Xeon berechnet.
Dafür ist der OpenCL Fehler weg. :)

Ich mach mal ein Catalyst update von 14.301.1004 auf 14.301.1006.

click to enlarge
Am Screen rechnet aber korrekt die Hawaii-GPU?!
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz