"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Nvme SSD Probleme mit PCIe4

Whiggy 04.10.2021 - 14:47 1195 12
Posts

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Hallo!
Ich benutze eine Samsung 980Pro SSD mit 2Tb für PCIe4.

Problem:
Immer wieder Abstütze von Spielen. Fehler im Ereignisprotokoll die auf NTFS hindeuten. Alles schon versucht: Firmwareupdate, Formatieren, Festplattenanalye, Neuinstallationen. Die Festplatte ist in Ordnung und zu warm ist sie auch nicht 52° unter Last.

Das Problem stellt sich immer so dar: Das Spiel stützt ab und es gibt NTFS Fehler im Ereignisprotokoll. Festplatte taucht zwar noch im Windows-Dateiexplorer auf, jedoch ist sie nicht mehr uneingeschänkt nutzbar. Z.b. löschen und kopieren von Dateien geht nicht mehr richtig und in Programmen wie Samsung Magicican oder auch anderen Benchmarktools, taucht die Platte gar nicht mehr auf. Nach einen Neustart des Rechners ist alles wieder in Ordnung.

Ich habe einen Workarround gefunden: Man muss im Bios von PCIe4 auf PCIe3 umstellen und das Problem ist gelöst. Jedoch verliert man dadurch viel Leistung. Ist halt die Frage ob der Controller auf der Platte defekt ist oder was Ähnliches.
Bearbeitet von Whiggy am 04.10.2021, 14:59

rad1oactive

knows about the birb
Avatar
Registered: Jul 2005
Location: Virgo Superclust..
Posts: 11152
Ist die SSD in einem pcie4 adapter oder geht die direkt auf pcie?
Hast du die Möglichkeit sie in einem anderen System zu testen?

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Zitat aus einem Post von rad1oactive
Ist die SSD in einem pcie4 adapter oder geht die direkt auf pcie?
Hast du die Möglichkeit sie in einem anderen System zu testen?

Die SSD ist direkt in dem dafür vorgesehen NVME Stackplatz am Mainboard (Direct CPU attachement)
Nein, hab keine Möglichkeit zum Testen.

Viper780

Er ist tot, Jim!
Avatar
Registered: Mar 2001
Location: Wien
Posts: 44013
Warum verlierst du mit PCIe 3 Leistung? so viel sollte das bei der Platte nicht sein

xtrm

social assassin
Avatar
Registered: Jul 2002
Location:
Posts: 10339
Die Leistung, die du von PCIe 4.0 auf 3.0 verlierst, merkst du bei normalen Anwendungsszenarien quasi nicht. Ja, die Leistung ist ca. halbiert, aber es sind noch immer ca. 3.5k MB/sec Lesen und Schreiben! Wie viele und wie oft schiebst du Daten umher, dass das wirklich eine Rolle spielt?

matiss

Chaos Maestro
Avatar
Registered: Dec 2007
Location: Vienna
Posts: 632
Laut der Beschreibung des Mainboards das in deiner Signatur steht hat es 4 M.2 Slots davon können aber nur 2 PCIe 4

2 x 2242-2280 support PCIe 4.0 x4 mode
1 x 2242-22110 supports PCIe 3.0 x4 & SATA modes
1 x 2242-22110 supports PCIe 3.0 x4 mode

Hast du die vielleicht in einem der PCIe 3 Slots drinnen und es spinnt deswegen?

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Zitat aus einem Post von matiss
Laut der Beschreibung des Mainboards das in deiner Signatur steht hat es 4 M.2 Slots davon können aber nur 2 PCIe 4

2 x 2242-2280 support PCIe 4.0 x4 mode
1 x 2242-22110 supports PCIe 3.0 x4 & SATA modes
1 x 2242-22110 supports PCIe 3.0 x4 mode

Hast du die vielleicht in einem der PCIe 3 Slots drinnen und es spinnt deswegen?


Nein.

Error404

Dry aged
Avatar
Registered: Mar 2006
Location: Ösareich
Posts: 2911
Eventuell ein Problem mit den verfügbaren Lanes?

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Zitat aus einem Post von Error404
Eventuell ein Problem mit den verfügbaren Lanes?

Nein. Es läuft mit 4 Lanes sowohl bei PCie 3 als auch bei PCie 4.

Graka 16 lanes + SSD 4 lanes = 20 verfügbare Lanes.
Passt also.

Error404

Dry aged
Avatar
Registered: Mar 2006
Location: Ösareich
Posts: 2911
Du sagst Firmware-Update gemacht, beim Board oder SSD?

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Zitat aus einem Post von Error404
Du sagst Firmware-Update gemacht, beim Board oder SSD?

Beides.
Ich hab mir mal eine neue SSD bestellt (diesmal eine Corsair) wenn das Problem dannach gelöst ist, dann geht die Samsung als Garantiefall zurück.

SaxoVtsMike

R.I.P. Karl
Avatar
Registered: Sep 2006
Location: ö
Posts: 7452
Zitat aus einem Post von Whiggy
Ich habe einen Workarround gefunden: Man muss im Bios von PCIe4 auf PCIe3 umstellen und das Problem ist gelöst. Jedoch verliert man dadurch viel Leistung.

Leistungsverlust bei einer Spiele SSD wenn man von pcie 4 auf pcie 3 switcht. Ja ich verstehe das es da einen Theoretisch messbaren Verlust in Benchmarks gibt, aber merken wirst das doch nirgends. Ich trau mir auch noch zu wetten das eine QVL@Sata6gb vom Durchsatz und response keine merklichen unterschied macht.
Funktionieren solls aber trotzdem, kann ja wirklich sein das die SSD einen knacks hat, hoffentlich ist da nicht auch noch das OS drauf.
Für Spiele würde ich heute nur noch die billigste nvme (wegen kabel) nehmen, selbst eine QVL schreibt schneller als die meisten Internetanschlüsse es hergeben

Whiggy

Here to stay
Registered: Nov 2000
Location: Klagenfurt
Posts: 2248
Themen-Update:

Gestern habe ich meine SSD gegen eine neue (selbes Modell von Samsung) getauscht.
Problem behoben. ISt wohl echt der SSD Controller defekt. Alte beim Etec zurückgegeben und Bares in voller Höhe erhalten. So muss dass!
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz