"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

RTX 4080 flackert über DP bei 2 von 3 Monitoren

RIDDLER 21.09.2023 - 23:54 2253 4 Thread rating
Posts

RIDDLER

Dual CPU-Fetischist
Avatar
Registered: Dec 2002
Location: Wien
Posts: 1841
Hi,

der neue PC ist fertig zusammen geschraubt und selbstverständlich gibt es ein nerviges Problem...

Es sind 3 (Asus-)Monitore in Verwendung und alle an eine MSI Ventus RTX 4080 über DP angeschlossen.
1x PG278QR (165Hz, G-Sync)
2x PB277 (75Hz, kein G-Sync)

An den beiden PB277 flackert das Bild. Soll heißen, dass Teile des Bildes sich in der rechten Hälfte des Bildes des nochmals für den Bruchteil einer Sekunde aufgebaut werden. Die Bildfehler sehen aus wie Speicherfehler. Der PG278QR funktioniert ohne Probleme.

Was habe ich bisher unternommen?
* Es ist eine frische W11 Installation und der letzte nvidia-Treiber ist installiert. Es hat auch vorher mit dem Windows Standardtreiber geflackert.
* DP Kabeln getauscht. Die Kabeln sind in Ordnung, da sie auch am PG278QR ohne funktionieren
* Die Problemmonitore über HDMI angesteckt --> funktioniert ohne Probleme.
* Auf der alten GTX1080TI funktioniert alles einwandfrei.
* Bios-Update durchgeführt (MSI B650 Tomahawk Wifi)
* Firmware-Update der GraKa durchgeführt bzw. nicht durchgeführt, weil das Tool sagte, dass die Karte up-to-date ist.
* Tuning/Optimierungen (zB Expo aktiviert, PBO angepasst, etc.) habe ich noch nicht durchgeführt. Alles stock mit (noch) sehr langsamen Einstellungen.

Was habe ich herausgefunden?
* Es ist kein Treiberproblem in Windows, denn im Bios habe ich diese Bildfehler auch.
* Reduzierung der Bildwiederholrate auf 60Hz löst das Problem.
* Mit der Änderungen der Bildwiederholrate auf dem PG278QR lässt sich das Problem nicht reproduzieren.
* Über DP lässt sich in Windows auf den beiden Monitoren nur eine maximale "krumme" Bildwiederholrate von 74,92Hz einstellen. Bei HDMI sind es exakt 75Hz.
* Funktioniert es beim PG278QR aufgrund von G-Sync? (Vermutung) Aber G-Sync ist ja keine Voraussetzung hierfür bzw. erfüllt einen gänzlich anderen Zweck.
* In den OSD der Monitore ist auch die in Windows eingestellte Bildwiederholrate ersichtlich. Daher dürfte die Kommunikation zwischen GPU und Monitore (halbwegs?) passen.

Any ideas? :confused:

tia
¿RIDDLER?
Bearbeitet von RIDDLER am 22.09.2023, 10:23

MaxMax

Here to stay
Registered: Jul 2001
Location: Wien
Posts: 1918
wie ich im anderen thread von dir schon mal schrieb: das mischen von aktiven gsync und nicht-gsync-fähigen TV oder Monitoren hat bei mir auch probleme gemacht (flickern, Hz setzen sich zurück...), jedenfalls hatte ich diese probs mit 3090er karte, obs vorher mit meinen Titans Xp (=sind fast dasselbe wie 1080Ti) probleme gab, kann ich mich nicht mehr erinnern. deaktivieren von gsync hat dann alle diese probleme auf der 3090 gelöst damals bei mir (mittlerweile fahre ich die kombi aber nicht mehr, hab nur noch 3x PG278QR an den SLI Titan Xp, und 4K/120Hz TV (hdmi 2.1)+ 120Hz 27" monitor (DP auf DVI adapter) an der 4090, alles ohne probs), auch unterschiedliche Hz auf den monitoren ist imho nicht "zuträglich" für ein supersauberstabiles system.

was mir noch einfallen würde:
a) sind keine (autostartenden) reduzierten Graka-Taktraten (unabsichtlich) irgendwo in msi afterburner o.ä. eingestellt? im multimonitorbetrieb muß der speichertakt der karte höher sein als im powermanaged singledisplay mode.

b) probier mal mit nvinspector "Multidisplay/Mixed-GPU-Acceleration" von single auf multidisplay performance mode zu stellen, oder compatibility.

c) probier mal mit nvinspector Powermanagement - Mode auf prefer maximum performance

d) probier mal mit nvinspector unter 2- sync and refresh: alle gsync beinhaltenden optionen auf "off", und ultra low latency enabled auf "off"

e) wg 74,92Hz problem: vl braucht windows irgendeine ini datei für die PB277, die die richtigen supported refresh rates mitteilt? oder vl. kannst eine benutzerdefinierte auflösung mit den richtigen Hz erstellen?

edit: ja das display port update firmware utility von nvidia war nur für maxwell und pascal karten gedacht imho.

xtrm

social assassin
Avatar
Registered: Jul 2002
Location:
Posts: 11918
G-Sync abdrehen wäre auch die erste Sache gewesen, die ich getestet hätte. Liegt bei diesem Problem auf der Hand. Aber wenn es im BIOS (??) auch passiert...das wäre äußerst seltsam.

Das mit den Hz ist mMn normal, mein Monitor zeigt in Win10 z.B. auch 143,975 Hz oder sowas um den Dreh an.

RIDDLER

Dual CPU-Fetischist
Avatar
Registered: Dec 2002
Location: Wien
Posts: 1841
Erstmals vielen Dank für die vielen Vorschläge.

@MaxMax
Du meintest das nVidia Control Panel und nicht den NVInspector, oder?

Es lag nicht am G-Sync-Geräte-Mix, denn das Problem tritt auch mit nur einem angeschlossenen Monitor auf.

Das Firmware-Update Tool wurde im November 2022 extra für 4090/4080 released.

Ich habe ein paar Punkte ausprobiert und dann hat es funktioniert.

Was ist die Lösung?
* Ich habe im nVidia Control Panel eine benutzerdefinierte Auflösung inkl. Refresh Rate angelegt. --> 2560x1440 mit 74Hz. Das Profil bei beiden Monitoren angelegt und übernommen und das war's :)

Es scheint, dass die vollen 75Hz aus irgendeinem Grund nicht "akzeptiert" werden. In den OSD der beiden Monitore steht jetzt auch 74Hz und es funktioniert :) Mit 1Hz niedriger als spezifiziert kann ich leben ;)

Das würde auch das flackern im Bios erklären. Ohne Treiber, etc. dürfte er vermutlich einfach mit der vollen Anzahl an Hz reinfahren und der Monitor sagt "nö".

Danke nochmals für die vielen Vorschläge.

xtrm

social assassin
Avatar
Registered: Jul 2002
Location:
Posts: 11918
Ah, sehr spannend, Danke für die Auflösung des Rätsels =).
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz