"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

[HELP]NAS Troubles (Qnap)

Captain Kirk 17.12.2019 - 13:00 2561 31
Posts

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
Sers,

ich hab grad Probleme mit meinem NAS und weiß grad nicht wie ich am besten vorgehe.
Hab ein QNAP 470, i7, 16GB, 4x4TB Raid 5 laufen.

Vor einiger Zeit hat HDD4 (wenige h, da relativ neu) SMART fehler geschrieben. Das war 3-4 Mal - hat sich aber mit der wöchentlichen Raid Bereinigung bzw. mit Unplug/plug beheben lassen.
Jetzt hat vor ca 1 Monat HDD0 (47000h) ebenfalls Fehler gemeldet.

Und seit gestern hab ich nun:
click to enlarge

Mir is klar dass ich früher handeln hätte sollen aber das Problem - 0 Zeit.
Jetzt bin ich allerdings etwas nervös was meine Daten angeht.

Wie geh ich am besten vor?
Wie wahrscheinlich ist es, dass der Controller was hat und wie wahrscheinlich, dass die Platten beleidigt sind.
Wäre das nur bei den 3 alten, würd ich ausschließlich auf die Platte tippen. Dass gerade die neueste auch Probleme gemeldet hat und jetzt wieder ruhig ist, bin ich unsicher.

Kann ich in diesem Zustand - Volume erstellen (läuft im loop) überhaupt die platte tauschen?


EDIT: ich überlege QNAP 672N als ersatz zu kaufen, will aber jetzt keinen hüftschuss machen. bin für alternativvorschläge offen. 4-6HDDs, 19" wär mir noch lieber ist aber nix in dieser preis/leistungs kategorie.
welche so-dimms nehm ich da am besten (16gb kit müsste reichen, tuts jetzt auch)?
klick

bin echt dankbar für hilfe. bin schon zulange weg aus dem "geschäft" :)
Bearbeitet von Captain Kirk am 17.12.2019, 13:28

Master99

verträumter realist
Avatar
Registered: Jul 2001
Location: vie/sbg
Posts: 11516
Gibts kein Backup bei >5 Jahre alten Platten?

Dann schleunigst ne >12TB Platte kaufen und via USB3 bespielen bevor du irgendwas anderes tust.

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
backup der dokumente gibts natürlich. der rest ist meine mediathek. die sind nicht gebackupt. mach ich noch.

strange find ich, dass jetzt lt. check alle smart werte der platten passen.

tialk

Here to stay
Avatar
Registered: May 2002
Location: vo/stmk
Posts: 3120
r5, ich hoffe du hast ein backup - Firmware kannst ja checken für deine Platten (ob es ein Update gibt)

wie gesagt ohne backup würd ich nix angreifen, ziehen, tauschen...

/e hopla, tab zu lange offen gehabt ;-)

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
wie check ich im laufenden nas die fw einer platte und wie kann ichs auch bspw. updaten?

Viper780

Er ist tot, Jim!
Avatar
Registered: Mar 2001
Location: Wien
Posts: 40000
im NAS ist sowas blöd - die meisten Firmware updates sind nur für Windows oder DOS

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
Hab mir jetzt mal das Qnap 672n bestellt.
+16gb RAM
3x4TB Platten hier im Forum

Nachdem der Volume rebuild nicht funktioniert, die Platte aber immer erkannt wird und auch der SMART Test ohne Fehler verläuft glaub ich nach wie vor an den Controller.

Nachdem ich theoretisch die Platten einfach ins neue Nas übersiedeln kann hätte ich jetzt mal folgendes vor:
1. Die 3 neuen einfach straight ins System ohne irgendeinen Verbund.
2. Backup (simple copy)
3. Platten raus, die vom alten versuchen alten 1:1 übersiedeln und schauen was passiert

Wenn alles klappt lass ich’s so mal laufen und erweitere dann das raid, wenns notwendig ist.

Einwände??

dosen

Here to stay
Avatar
Registered: Feb 2003
Location: Wien
Posts: 5336
Gleiches Verhalten hatte ich bei einem 8-Bay Qnap vor ein paar Monaten. Zwei Platten haben sich ca. einmal die Woche spontan getrennt. Danach Raid Bereinigung (Raid 6) und keine Smart Fehler.

War die Backplate vom Qnap, wurde eingeschickt und repariert.

Gentleman

Big d00d
Registered: Aug 2018
Location: Wien
Posts: 266
Du hast noch immer kein Backup des R5 gemacht?

Punkt 2 deines letzten Beitrags ist was genau?
Eine Kopie der Chunks? Imho ziemlich sinnlos.

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
So. Kleine Teilerfolgsgeschichte.

Also es war mal definitv eine defekte HDD, wenn auch mit sonderbarem Defekt. Dh. mal gings, dann wieder nicht, Smart OK. kA
Alle Daten da, alles gut soweit.
Hab mich dazu entschieden das neue Nas zu behalten. Ist nun bestückt mit:
5x 4TB WD RED
1x M.2 Corsair MP510 500GB
16GB Ram
i3 8 Gen

Nun gibts aber leider 2 Probleme.

1. ich hab eine zusätzliche 4TB HDD reingesteckt um die Kapazität zu erweitern und kA was ich da falsch gemacht habe aber die Kapazität hab ich dadurch nicht erweitert. Ich vermute mal, dass ich eine zusätzliche Spare Disk habe, auch, wenn ich nicht wüsste wie ich das gemacht habe und ich eigentlich dachte, dass das bei Raid 5 nicht möglich ist. Punkt ist, dass ich nun anstehe und nicht genau weiß was ich machen soll.

2. ich habe random reboots. Das Log ist leider wenig aus ausser, dass das System beim letzten Mal nicht richtig runtergefahren wurde.

Mit Punkt 2 hab ich mich mal an den Support gewandt. Mal schauen was da kommt. Der ist ja bekanntlich nicht der Schnellste... :rolleyes:

Help welcome, tia

roscoe

Addicted
Avatar
Registered: Mar 2005
Location: 1050 Wien
Posts: 402
HDs, die keine SMART Fehler haben aber trotzdem spinnen hab ich auch schon gesehen, in den letzten beiden Fällen waren das spontane Connects/Disconnects.

Gentleman

Big d00d
Registered: Aug 2018
Location: Wien
Posts: 266
Wie viele Daten hast du drauf?
Was sagt der QNAP Storage Manager über den Status des R5 und der Spindeln?

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
Zitat aus einem Post von roscoe
HDs, die keine SMART Fehler haben aber trotzdem spinnen hab ich auch schon gesehen, in den letzten beiden Fällen waren das spontane Connects/Disconnects.
genau so wars bei meiner defekten.

@Gentleman:

click to enlarge
click to enlarge
Bearbeitet von Captain Kirk am 01.02.2020, 20:20

Gentleman

Big d00d
Registered: Aug 2018
Location: Wien
Posts: 266
Was sagt das Ausrufezeichen (links oben)?
Online Expansion ongoing, oder geht es nur offline?
Warum hast du Bitmap nicht aktiviert?

Captain Kirk

Fanboy von sich selbst
Avatar
Registered: Sep 2002
Location: NCC-1701
Posts: 6259
Bin grad im Urlaub.
Bzgl. Bitmap... was trinkst du gern? Hast mal Zeit? :D
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz