"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Performanceprobleme am X200s unter xubuntu 14.04

tinker 01.01.2016 - 16:22 3133 16
Posts

tinker

SQUEAK
Avatar
Registered: Nov 2005
Location: Wien
Posts: 4952
Ahoi,
seit einiger Zeit kämpfe ich auf meinem X200s mit Performanceproblemen. Fällt vor allem beim surfen auf, denn viel mehr mach ich aktuell nicht damit. Wobei, Matlab hatte letztens auch mal gröbere Performance Probleme in der IDE, als ich kurz was schaun wollte.

Hier mal ne Auflistung einiger wichtiger Daten:

X200s
Core2Duo L9400 @ 1.86GHz
3GB RAM
Samsung 830 128 GB
OS is Xubuntu 14.04

Ich tippe ja auf die SSD, denn irgendwie schauen mir die R/W Werte ja nicht so gut aus. Könnt aber auch an nem anderen Problem liegen:
Code:
hdparm -Tt /dev/sda

/dev/sda:
 Timing cached reads:   9142 MB in  1.99 seconds = 4585.55 MB/sec
 Timing buffered disk reads: 654 MB in  3.01 seconds = 217.56 MB/sec

---

dd if=/dev/zero of=tempfile bs=1M count=1024 conv=fdatasync,notrunc

1024+0 records in
1024+0 records out
1073741824 bytes (1,1 GB) copied, 18,1028 s, 59,3 MB/s

---

tee /proc/sys/vm/drop_caches

---

dd if=tempfile of=/dev/null bs=1M count=1024

1024+0 records in
1024+0 records out
1073741824 bytes (1,1 GB) copied, 11,0766 s, 96,9 MB/s
Auffallend sind dabei die niedrigen Read und Write Werte von dd. Wobei dd ja von partition alignment abhängt, aber parted sagt mir dass die SSD eh aligned ist:
Code:
parted /dev/sda align-check opt 1
1 aligned
Sonst hier noch der output von fdisk:
Code:
fdisk -l -u /dev/sda

Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d119b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   243990527   121994240   83  Linux
/dev/sda2       243992574   250068991     3038209    5  Extended
/dev/sda5       243992576   250068991     3038208   82  Linux swap / Solaris
Die 830er läuft mit der Firmware CXM03B1Q und laut samsung-website ist das auch die aktuellste Firmware für die 830er.

Und jetzt steh ich grad irgendwie an. Denn mein erster Gedanke wär ein Firmware Update für die SSD gewesen, nur wenn eh schon die aktuelle oben ist, hat sich das erledigt. Im Betrieb ist die SSD seit Okt. 2012.

Laufen tut das System mit xubuntu 14.04 seit Okt. 2014. Davor hatte ich arch mit xfce oben. Seit wann ich die Performance Probleme hab, kann ich nicht genau sagen. In letzter Zeit fällts mir auf jeden Fall verstärkt auf.

tia
Bearbeitet von tinker am 01.01.2016, 16:23

Crash Override

BOfH
Registered: Jun 2005
Location: Germany
Posts: 2951
Versuch noch mal mit 8MB Blocksize, da sollte die SSD noch schneller werden. Ich glaube eher das dir der Ram bei modernen Browsern ausgeht sowie die CPU Leistung bei einigen Webseiten.

xtrm

social assassin
Avatar
Registered: Jul 2002
Location:
Posts: 9760
Welchen Browser nutzt du? Erfahrungsgemäß kann ich sagen, dass 3 GB RAM zum Surfen absolut ausreichend sind, hatte ich bis vor kurzem sogar am Desktop PC und das war kein Problem, auch mit mehreren Tabs und YouTube und so weiter. Die CPU-Power könnte jedoch wirklich eine der Ursachen sein.

tinker

SQUEAK
Avatar
Registered: Nov 2005
Location: Wien
Posts: 4952
Habs jetzt mal mit 8MB blocksize probiert (bs=8M count=128), ändert nicht wirklich was. Write um ~1 MB/s schneller, read dafür ~1.5 MB/s langsamer.

Browser is Firefox in der aktuellen Version. Davor lange chromium. Bin am Desktop unter Windows von Chrome auf Firefox gewechselt und dann am notebook nachgezogen. Vllt sollt ich da mal wieder chromium probieren.

Ich mein arch -> ubuntu wird ja nicht das Problem sein, nachdem ich eh xfce verwend.

tinker

SQUEAK
Avatar
Registered: Nov 2005
Location: Wien
Posts: 4952
Ich halte aktuell eigentlich nach einem refurbished T430s Ausschau, um das x200s abzulösen.

Jetzt stellt sich mir aber doch die Frage, ob ein Ram-Upgrade beim x200s nicht auch ausreichend wäre. Oder scheiterts wohl wirklich an der CPU Performance, wie xtrm schon gemeint hat?

davebastard

Vinyl-Sammler
Avatar
Registered: Jun 2002
Location: wean
Posts: 8711
Ram lässt sich ja relativ leicht feststellen:

free -m eingeben wenns mal wieder langsam ist und spalte "free", die zahl bei "-/+ buffers/cache"

tinker

SQUEAK
Avatar
Registered: Nov 2005
Location: Wien
Posts: 4952
Bei mir freezed das System aber meistens gleich und ich muss rebooten. Aber werd mit free trotzdem mal versuchen zu schaun, danke!

// Aber gut, aktuell hab ich chromium mit 8 Tabs offen und es sind noch 387mb frei... was sich nicht nach viel anhört.

Code:
              total        used        free      shared  buff/cache   available
Mem:           2904        1802         387         304         715         597
Swap:             0           0           0
Bearbeitet von tinker am 06.10.2016, 11:33

Master99

verträumter realist
Avatar
Registered: Jul 2001
Location: vie/sbg
Posts: 11712
freezen/reboot dürfte bei 'nur' RAM voll aber halt eigentlich auch nicht sein... sehr zach/langsam ja, aber freeze? mhm...

auf nem alten wiederbelebten laptop lief übrigens debian mit xfce um einiges besser als xubuntu... sowohl ram- als auch cpu-auslastung war bei gleicher workload geringer.

verwendest du einen adblocker, wenn ja welchen? ublock origin braucht z.b. einiges weniger ressourcen als adblock plus.

tinker

SQUEAK
Avatar
Registered: Nov 2005
Location: Wien
Posts: 4952
hm, freeze is es eigentlich eh nicht. aber es is so zach langsam, dass sich der mauszeiger erst einige sekunden später bewegt und mausklicks teilweise garnet verarbeitet werden (oder es wird mir zu blöd und ich starte neu)

habs jetzt übrigens versucht bisserl zu provozieren:
chromium mit kA 10 tabs offen, darunter ein laufendes youtube video und matlab

free -m output:
Code:
              total        used        free      shared  buff/cache   available
Mem:           2904        2333          79         373         491          41
Swap:             0           0           0
screenshot von top:
click to enlarge

allgemein braucht mir der browser irgendwie zu viel, wie schon im letzten post, bei drei offenen tabs (oc.at, gmail, google calender) nur noch ~380mb frei... (edit: ok, waren vorhin mehr tabs. jetzt bei den dreien sind 675mb frei)

es is chromium und ich erwend uBlock origin und uMatrix (noscript ersatz)
Bearbeitet von tinker am 06.10.2016, 11:59

t3mp

I Love Gasoline
Avatar
Registered: Mar 2003
Location: upstairs
Posts: 6182
Kann ich eigentlich überhaupt nicht nachvollziehen, Plasma-5.8.0 mit Gentoo @X200s mit 8GB RAM. Sicher ist scrollen nicht immer ganz flüssig, da hab ich allerdings auch das letzte Firefox Upgrade ein wenig im Verdacht. Mauszeiger ist immer instant und Mausklicks werden alle angenommen. Ich hab hier zig Tabs offen. Natürlich steht meinem System mehr RAM-Buffer zur Verfügung.

Code:
$ free -m
              total        used        free      shared  buff/cache   available
Mem:           7869        2720        1181         542        3967        4006
Swap:          8191           0        8191

COLOSSUS

# pkill -9 .
Avatar
Registered: Dec 2000
Location: Wien || Stmk
Posts: 10970
Du hast keinen Swapspace aktiv, aber kswapd konsumiert laut top 22% CPU? Da versucht irgendwas zu pagen (vielleicht verwendet eines der Programme, das du verwendest, gut gemeinte madvise()-Calls auf grosze Allokationen), und verursacht damit sinnlose, weil auf deinem System unerfuellbare Arbeit fuer deine CPU.

Versuch mal, ob du dich mittels `sysctl -w vm.swappiness=0` da rauswinden kannst und eine Verbesserung spuerst.

Crash Override

BOfH
Registered: Jun 2005
Location: Germany
Posts: 2951
Kein Wunder das die Maschiene Prozesse wegschießt ohne SWAP. Konfiguriere erst einmal einen sinvollen SWAP, ansonsten bekommst du den Rechner nicht stabil.

COLOSSUS

# pkill -9 .
Avatar
Registered: Dec 2000
Location: Wien || Stmk
Posts: 10970
Aber das passiert doch gar nicht? Nichts, was tinker geschrieben hat, deutet darauf hin, dass der OOM-Killer aktiv wird.

Paging macht die Performance-Situation jedenfalls bestimmt nicht besser.

davebastard

Vinyl-Sammler
Avatar
Registered: Jun 2002
Location: wean
Posts: 8711
ja leg einfach ein swapfile an, dann brauchst auch nix an deinen partitionen ändern.
bei so wenig RAM ist es ned schlecht swap zu haben.

//performance mäßig wirds allerdings ned viel bringen, wenn mit freezes gemeint ist dass sich apps auch komplett aufhängen dann könnts helfen.
Bearbeitet von davebastard am 06.10.2016, 13:12

COLOSSUS

# pkill -9 .
Avatar
Registered: Dec 2000
Location: Wien || Stmk
Posts: 10970
Meine Meinung dazu: Wenn du kein Supsend to Disk einsetzt, ist es schlecht, Swap zu haben.

Wenn dir irgendwas so viel Speicher frisst, dass es sich physisch nicht mehr ausgeht, musst du aufruesten - Punkt. Alles andere ist bestenfalls eine Interimsloesung, und i. A. wird (auch beim Swappen auf SSD oder NVMe) alles so vergleichsweise unfassbar und unertraeglich lahm, dass du dir wuenscht, der OOM-Killer haette einfach alles Stoerende abgeknallt, anstatt dass du nach einigen Minuten bangem bis kochen-wuetendem Warten den Power-Switch unweigerlich selbst durchdureckst.
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz