"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

GPUPI 3 ist final!

mat 05.04.2018 - 00:11 27898 54 Thread rating
Posts

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Umlüx, du bist nicht zu blöd, ich bin es. :)
Es gab einen Fehler im Kernel für ältere AMD-Grafikkarten und einen Fehler bei der Auswahl mit dem CLI-Parameter -a.

Neues Bugfix-Release kommt in Kürze!

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
GPUPI 3.3.1

Downloads:

Changelog:
  • Bugfix für Kernel-Kompilierung bei älteren AMD-Grafikkarten
  • Bugfix für Command Line Modus bei der Nutzung des Parameters "-a" (API-Auswahl)
  • Verbesserte Fehlermeldung (+ Tipp) bei einem etwaigen Driver-Reset durch den Watchdog Timer (nur für CUDA bei einer Kerneldauer von über 5 Sekunden, passiert nur bei sehr alten oder sehr schwachen Grafikkarten in Verbindung mit zu hoher Batch Size)
  • Verbesserte Fehlermeldung (+ Tipp) beim Anstoßen an ein Ressourcen Limit in OpenCL (zB bei älteren AMD-Grafikkarten in Verbindung mit Reduction Size 512)
  • Bugfix für Multi-GPU-Berechnungen: Sollte eine der Devices aufgrund eines Fehlers abbrechen, wird nun die gesamte Berechnung abgebrochen.

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Zitat aus einem Post von Paxi
Hab dir gestern noch eine PM geschickt. Wollte nur sichergehen, dass sie nicht untergeht und du hier im Thread ja sehr aktiv bist.
Du hast eine PM. :)

Umlüx

Huge Metal Fan
Avatar
Registered: Jun 2001
Location: Kärnten
Posts: 8156
Zitat aus einem Post von mat
Umlüx, du bist nicht zu blöd, ich bin es. :)
Es gab einen Fehler im Kernel für ältere AMD-Grafikkarten und einen Fehler bei der Auswahl mit dem CLI-Parameter -a.

Neues Bugfix-Release kommt in Kürze!


Bärfekt! :D

unbenannt_229878.png

EDIT:

mit der Iris 540 im surface 4 gibts anscheinend auch was. log anbei
debug_log_229879.txt (downloaded 109x)
Bearbeitet von Umlüx am 06.04.2018, 12:44

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Danke, werde ich fixen!

UnleashThebeast

Kabelbinder = Todesstrafe
Avatar
Registered: Dec 2005
Location: 127.0.0.1
Posts: 2438
Timer: Invariant TSC (1.48 MHz)
Init HWiNFO: Ok

Intel OpenCL 2.0
- Intel HD Graphics 515 (24 CUs, 1000 MHz, OpenCL 2.0)
Compiling OpenCL kernels ..

Error: Could not set reduction kernel arguments: CL_OUT_OF_RESOURCES (#-5, Device: HD Graphics 515)


:(

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Probiers mal mit Reduction Size 256 oder noch kleiner, falls nötig. Die HD 515 bringt nicht genug Shared Memory für so große Reductions mit.

UnleashThebeast

Kabelbinder = Todesstrafe
Avatar
Registered: Dec 2005
Location: 127.0.0.1
Posts: 2438
Ah ok, hab einfach Standardwerte eingestellt gelassen.

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Letztes Bugfix-Release für heute: GPUPI 3.3.2

Downloads:

Changelog:
  • Bugfix: Abstürze beim Speichern des Result-Files behoben
  • Bugfix: Probleme beim Kompilieren der OpenCL Kernel auf Intel iGPUs behoben
  • Die Erkennung des Speicherherstellers ist heikel und kann Abstürze verursachen, deshalb wird sie nun beim HWiNFO "Safe Mode" ausgelassen
  • Verbesserte Fehlermeldung wenn der OpenCL Reduction Kernel nicht ausreichend Shared Memory hat, um initialisiert zu werden (passiert nur auf schwachen iGPUs)

Danke an alle, die mitgeholfen haben!

:ghug:

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 11471
ich bekomms auf dem 880G / phenom II 1055T hier irgendwie nicht zum laufen, sagt immer openCL.dll fehlt, auch nach installation vom AMD openCL treiber.

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Dann ist die OpenCL.dll in einem Verzeichnis, das nicht in der PATH-Umgebungsvariable drinnen ist. Am besten du suchst sie im System und kopierst sie in das GPUPI-Verzeichnis.

Ich habe schon etwas herumgespielt, ob GPUPI eine OpenCL.dll standardmäßig mitliefern. Ich denke, dass ich das noch ordentlich testen muss bevor es soweit ist.

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 11471
ich find nur eine amd_opencl32.dll und amd_opencl64.dll, wenn ich die reinkopier und umbenenne kommt
Code:
Error: Could not fetch number of available OpenCL platforms: Unknown OpenCL error code: -1001
Error: Could not query for available OpenCL devices!

Umlüx

Huge Metal Fan
Avatar
Registered: Jun 2001
Location: Kärnten
Posts: 8156
Zitat aus einem Post von mat
Letztes Bugfix-Release für heute: GPUPI 3.3.2

funzt nun auch mit der Iris 540, Danke! :cool: :D

mat

Administrator
Legends never die
Avatar
Registered: Aug 2003
Location: nö
Posts: 24911
Zitat aus einem Post von InfiX
ich find nur eine amd_opencl32.dll und amd_opencl64.dll, wenn ich die reinkopier und umbenenne kommt
Code:
Error: Could not fetch number of available OpenCL platforms: Unknown OpenCL error code: -1001
Error: Could not query for available OpenCL devices!
Diese Dateien ins GPUPI-Verzeichnis zu reinzukopieren, ist keine gute Idee. Die sollten dort liegen, wo das AMD APP SDK sie installiert.

Schaut dir mal folgenden Registry-Key an: HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenCL\Vendors

Dort sollte eine Liste aller installierten OpenCL Driver sein. Bei mir sieht es so aus:

click to enlarge

Am besten du deinstallierst das AMD APP SDK noch einmal und installierst es neu. Die richtige Version ist übrigens 2.9-1 (64 bit, falls du ein 64 bit OS hast): https://developer.amd.com/amd-accel...essing-app-sdk/

InfiX

she/her
Avatar
Registered: Mar 2002
Location: Graz
Posts: 11471
danke, schau ich mir mal an :)

e: ok da hatte ich wohl den falschen treiber, mit dem SDK gehts und hab jetzt auch den registry eintrag, nur hängt sich GPUPI jetzt einfach direkt auf

Code:
Faulting application name: GPUPI.exe, version: 3.3.2.0
Faulting module name: amdocl64.dll, version: 10.0.1445.5
Exception code: 0xc0000005
Fault offset: 0x00000000000575ae
Faulting process id: 0x121c
Faulting application path: D:\Software\GPUPI 3.3.2\GPUPI.exe
Faulting module path: C:\Program Files (x86)\AMD APP SDK\2.9-1\bin\x86_64\amdocl64.dll

e2: bei google find ich lediglich 2 einträge mit dem gleichen problem bei openCL anwendungen allerdings ohne lösung.
Bearbeitet von InfiX am 06.04.2018, 15:10
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz